Major outage
Incident Report for Connecteam
Resolved
This incident has been resolved.
Posted Jun 19, 2023 - 18:02 UTC
Update
We are investigating the issue
Posted Jun 19, 2023 - 16:11 UTC
Investigating
We are currently investigating this issue.
Posted Jun 19, 2023 - 16:10 UTC
This incident affected: Platform.