Performance Issues
Incident Report for Connecteam
Resolved
This incident has been resolved.
Posted May 16, 2022 - 21:00 UTC
Investigating
We are currently investigating this issue. We are experiencing performance issues across the entire platform. We'll update you as soon as we have more information! We really appreciate all your patience while our dev team works to get the system back up and running smoothly.
Posted May 16, 2022 - 15:42 UTC
This incident affected: Platform.