Major Outage
Incident Report for Connecteam
Resolved
This incident has been resolved.
Posted Feb 18, 2023 - 01:00 UTC
Investigating
We're experiencing connectivity issues for all accounts across all devices. Our development team works on the case diligently to resolve this matter as quickly as possible.
Posted Feb 17, 2023 - 22:47 UTC
This incident affected: Platform.