Major Outage
Incident Report for Connecteam
Resolved
This incident has been resolved.
Posted Mar 13, 2023 - 15:15 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 13, 2023 - 14:28 UTC
Investigating
We are currently investigating this issue
Posted Mar 13, 2023 - 14:25 UTC
This incident affected: Platform.